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5.   Tutorial 

Starting FlashCut CNC 

To start FlashCut CNC, click on the Start button, select Programs, select FlashCut 

CNC 4, then select the FlashCut CNC 4 icon. 

A dialog will appear asking you if you want to start with the Signal Generator 

connected.  Choose the Don’t Connect button.  If you’re running the Demo 

version, choose Continue. 
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Configuring FlashCut CNC 

1. Choose New Setup from the File menu. 

 

2. The configuration wizard will appear.  Answer the questions in the wizard to 

create a default setup file for your machine.  If you’re using the Demo version 

of the software, you don’t need to do anything else here.  If you’re using the 

live version of the software and running your machine tool, you’ll need to 

finish configuring the setup file for your machine.  Please refer to Initial Setup 

section of this manual for more details. 

3. Choose DRO:All Coordinates from the View menu to make sure all four 

coordinate systems are displayed. 

4. Choose Viewports from the Configuration menu.  Set the View On 

checkboxes so only the following viewports are displayed:  Z, XY, and XYZ. 
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Loading a G-Code File 

1. Choose Open G-Code from the File menu. 

 

2. Double-click on the file TUTOR.FGC. 

FlashCut will load TUTOR.FGC and the screen should now look like this: 



FlashCut CNC Section 5  Tutorial 

 
262 

 

Notice how the G-Code listing appeared in the Program Listing Box and a red 

outline of the toolpath appeared in the Viewport Box. 

Viewing the Toolpath 

Before examining the toolpath display let’s zero the machine coordinates.  To do 

this, choose Zero All from the Set button to the right of the Machine label in the 

DRO Box.  Choose Yes in the confirmation dialog that follows. 

The machine coordinates, previously shown as N/A, will now be zeroed and a 

light blue box will outline the tool envelope in the Viewport Box.  Because Auto 

Zoom Toolpath Extents is checked in the View menu, you’ll only see a portion of 

the tool envelope boundary, as shown below. 
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To see the entire machine tool envelope, choose Auto Zoom Machine Extents 

from the View menu.  The screen will then appear like this: 

 

Choose Auto Zoom Toolpath Extents from the View menu again, to see the 

largest possible image of the toolpath. 

Now let’s get familiar with the Viewport Box.  Here are some important features: 
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Red Lines – Represent the toolpath for the G-Code program. 

Green Dot – Represents Program Zero, the origin of any G-Code program. 

Light Blue Dot – Represents Machine Zero, also called Home. 

Yellow Dot (not shown here) – Represents the current XY position of the 

machine tool during the cutting operation. 

Thick Blue Lines (not shown here) – Represent the portion of the toolpath 

already cut. 

Dotted Lines – Represent a rapid move. 

Solid Lines – Represent a feedrate move. 

Tool Icon – Represents the current Z axis position relative to the 

workpiece (bottom of icon) and relative to the machine (near top of icon). 

Light Blue Lines – Represent the borders of the machine tool envelope. 

Animating the G-Code File 

Now we’re ready to animate and verify the toolpath on the screen. 

1. On the Controller menu, make sure the Simulate When Not Connected 

command is checked. 

 

2. Choose Zero All from the Set button next to the Program label, and then 

choose OK in the confirmation dialog box that follows.  FlashCut sets all 

program coordinates to zero.  This simulates the tool being in the correct 

position before the G-Code program begins. 

3. Choose the G-Code button in the Control Selection Box to make sure the G-

Code Control Panel is displayed. 

4. Select the Step radio button so FlashCut will execute the G-Code program one 

line at a time. 

5. Choose the Start button and watch the tool icon move down the Z axis 

viewport.  Notice that FlashCut has highlighted the next line in the Program 

Listing Box, indicating it has fully executed the first line. 

6. Choose the Start button again.  Notice the yellow dot, which represents the 

current position of the tool, and the solid blue line, which represents the 

cutting move just executed. 

7. Select the Continuous radio button, and then choose the Start button again.  

The yellow dot moves along the toolpath to completion, leaving a blue trace 

behind. 
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Editing a G-Code File 

Now let’s get familiar with using the FlashCut editor. 

1. Choose Editor from the File menu.  The editor dialog box will appear. 

 

2. First, let’s reduce the cutting depth from 2.25” to 0.25”.  With your mouse or 

your arrow keys, move the cursor to the first line of G-Code that reads:  G01 

Z-2.25 F5.0.  Change it to read:  G01 Z-0.25 F5.0.  Then choose Update 

Toolpath at the bottom of the editor dialog box.  Notice how the red line in the 

Z viewport, which shows the total length of Z travel, shrinks down to 0.25” 

long. 

3. Now, let’s change the diameter of the arc we’re cutting.  Move the cursor to 

the line of G-Code that reads:  G03 X4.0 Y1.0 I0.0 J0.5.  Change it to read:  

G03 X4.0 Y2.0 I0.0 J1.0.  Choose Update Toolpath to see the effect of the 

change. 

4. To save your changes: 

 Choose Save G-Code As from the editor’s File menu. 

 Type “TUTOR2.FGC” in the File name box. 

 Choose OK. 

5. To close the editor, choose Close. 

Connecting with the Signal Generator 

Now you’re ready to have FlashCut establish communications with the Signal 

Generator.  Note that when the Signal Generator is connected, all moves will be 

performed by the machine tool.  If you’re running the Demo version of FlashCut 

or do not have the means to connect to the Signal Generator at this time, ignore 

this section and continue with “Using the Jog Controls” below. 
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1. Make sure that Signal Generator is securely connected via USB cable to your 

PC, and you’ve completed the USB driver installation. 

2. Turn on the Signal Generator. 

3. Choose Connect from the Controller menu. 

  

4. FlashCut will display the Safety First message.  Please read the message 

carefully.  If you agree with the safety guidelines, click Agree. 

Using the Jog Controls 

The jog controls let you manually position the tool anywhere within the machine 

tool envelope. 

1. Choose the Jog button in the Control Selection Box.  FlashCut displays the 

Jog Control Panel. 

 

2. Select the Slow and Contin (Continuous) radio buttons.  The machine tool will 

move continuously at the slow jog rate (defined on the Jogging panel of the 

Configuration dialog box.) 

3. Check the machine tool to make sure there’s enough room to move the tool in 

the Z+ direction.  If there is enough room, click down, hold and then release 

the Z+ jog button.  Notice how the tool moved up and the Z program and 

relative coordinates changed.  Also notice how the machine moved until you 

released the button.  If the tool went down instead of up, change the Motor 

Direction for the Z axis on the Motor Signals panel of the Configuration 

dialog box.  Note that when machine coordinates are being used, FlashCut 

will not let you move beyond the machine tool envelope.  Also note that you 

can jog the machine using the keyboard.  The controls are mapped as follows: 
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X+ Ctrl + Right Arrow Key 

X- Ctrl + Left Arrow Key 

Y+ Ctrl + Up Arrow Key 

Y- Ctrl + Down Arrow Key 

Z+ Ctrl + Page Up Key 

Z- Ctrl + Page Down Key 

A+ Ctrl + Plus (+) Key 

A- Ctrl + Minus (-) Key 

4. Try jogging in all directions on all axes, making sure you have enough room 

in the direction of travel before you choose each axis jog button. 

5. Now select the Fast radio button and repeat the same exercise.  The tool will 

move at the fast jog rate defined on the Jogging panel of the Configuration 

dialog box.  

6. Position the tool so there is at least 1” of room in the positive Z direction. 

7. Now let’s set the current position as program coordinates X=0, Y=0, Z=1.  

First, choose Enter from the Set button next to the Program label in the DRO 

Box.  Then choose the Zero X and Zero Y buttons.  Finally, enter 1.0000 in 

the Z text box.  Choose OK to exit the dialog. 

8. Now let’s use the jog buttons to move the tool up exactly 1.0000”.  It’s 

convenient to use three jog modes to do this:  Fast Continuous, Slow 

Continuous and Slow Step. 

9. While the jog rate is still set to Fast, move the tool up until the Z axis program 

coordinate is close to 2”. 

10. Now change the jog rate to Slow and do the same to get even closer to 2”.  

11. Finally, change the jog mode to Step.  FlashCut will move the tool exactly one 

step each time you choose one of the jog buttons.  Repeatedly choose either 

the +Z or -Z Axis Jog button until the tool is exactly at program coordinate 

2.0000 on the Z axis.  Depending on the tool positioning resolution of your 

machine tool, you might not be able to reach 2.0000 exactly. 

12. Now use the same process to move the tool exactly 0.5000 inches in the +X 

direction and 0.2500 inches in the +Y direction.  The program coordinates 

should now read: 

X:  0.5000 

Y:  0.2500 

Z:  2.0000 
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Setting Machine Zero 

In general you can set Machine Zero two ways:  manually by jogging the tool to 

the corner of the machine tool envelope and choosing Zero All from the machine 

coordinates Set button, or by using the Seek Home button on the Home Control 

Panel.  In this tutorial we will jog to a point and manually define it as Machine 

Zero.  (To use the Seek Home button, your machine must have homing switches 

installed.) 

Follow these steps to set Machine Zero manually. 

1. Choose Clear from the Set button next to the machine coordinate label in the 

DRO Box.  This will clear the machine coordinates and remove the light blue 

machine tool envelope boundary. 

2. Choose the Jog button in the Control Selection Box.  

3. Jog the tool to 1/10” from the top of the Z axis. 

4. Jog the table in the X- direction to about 1/10” from the end of travel.  

5. Jog the table in the Y- direction to about 1/10” from the end of travel.  

6. Choose Zero All from the Set button to the right of the machine coordinate 

label.  Then choose OK in the confirmation dialog box that follows. 

Using the Point Move 

The Point Control Panel provides an easier way to move the tool to an exact 

position. 

1. Choose the Point button in the Control Selection Box. 

2. Select Any Point in the Point List. 

3. Select Machine from the coordinate system pull-down menu. 

4. Fill in the X, Y and Z text boxes to read 1, 2, and -1. 
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5. Enter “4” in the Linear Feedrate text box.  Now everything is ready to move to 

machine coordinates 1, 2, -1 at a feedrate of 4 inches/minute. 

 

6. Choose the Move button.  Notice how the machine first performed 2-Axis 

linear interpolation for the X and Y axis, then moved the Z axis down.  This 

sequence of movement, unique to the Point mode and G28/G29/G30 

commands, helps to avoid tool crashes. 

7. Select Machine Zero in the Point List. 

8. Select Rapid from the Rate Mode pull-down menu.  Everything is set to move 

the tool to machine coordinate 0, 0, 0 as quickly as possible. 

 

9. Choose the Move button.  Notice how the machine first moved the Z axis up 

and then performed 2-axis linear interpolation on the X and Y axes. 



FlashCut CNC Section 5  Tutorial 

 
270 

Setting Program Zero on the Machine Tool 

Program Zero is the origin to which all program coordinates in the G-Code file 

are referenced.  Before we cut a part, Program Zero must be set correctly relative 

to the workpiece.  For this tutorial we will cut a file called FLASHBOLT.FGC.   

1. Choose Open G-Code from the File menu and select FLASHBOLT.FGC, and 

then choose OK.  The screen appears like this: 

   

2. Make sure there is enough room on all axes of the machine to run this G-Code 

file from the Program Zero point.  By observing the toolpath displayed in the 

Viewport Box, you’ll see the FLASHBOLT.FGC program needs +2.125 

inches on the X axis, +1.625 inches on the Y axis, +0.5 and -0.05 inches on 

the Z axis. 

3. Fixture a sheet of 1/8” or thicker plastic or aluminum at least 2” wide and 4” 

long onto the XY table of the machine tool.  Be sure that all clamps and 

fixtures are well out of the way of the tool during all parts of the program.  

This program works best with a 1/16” end mill. 

4. Jog the tool to the X-, Y- corner of the workpiece using the Jog Control Panel.  

Then carefully jog the tool down in the Z axis until it just barely touches the 

top of the workpiece. 

5. To define this point as Program Zero, choose Zero All from the Set button 

next to the Program label.  Then choose OK in the dialog that immediately 

follows. 
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6. Using either the Jog or Point Control Panel, raise the Z axis exactly 1.0” and 

define this point as Program Zero.  Note that this point is exactly 1” above 

where it needs to be to actually cut the workpiece.  The machine is now ready 

to do a dry run without cutting the workpiece.  

Testing the Program on the Machine Tool 

It is always a good idea to do a dry run of the G-Code file, both connected and not 

connected to the Signal Generator, before cutting a part.  This lets you check for 

G-Code programming errors, spot interferences with fixtures, and so on. 

1. Choose the G-Code button in the Control Selection Box. 

2. Choose the Reset button to make sure the G-Code program is reset.  Choose 

OK in the dialog that follows. 

3. Disconnect from the Signal Generator by choosing Disconnect from the 

Controller menu. 

4. Go into step mode by choosing the Step radio button. 

5. Repeatedly choose the Start button, watching the screen to make sure the tool 

behaves properly. 

6. Once you are satisfied the program will behave properly, re-establish 

communications with the Signal Generator by choosing Connect from the 

Controller menu.  A dialog will ask you if you want to revert to the 

coordinates used before disconnecting.  Choose Yes. 

7. Choose the Step radio button. 

8. Choose the Start button.  The machine should move the X and Y axes, and 

then stop. 

9. Step through the entire program by choosing the Start button for every line of 

G-Code.  If at any time you need to stop the tool, choose the Feed Hold button 

or hit any key on your keyboard.  If you stop the tool in the middle of the 

program, you can start exactly where you left off by choosing the Start button.  

You may want to try this for practice. 

Cutting the Part 

Assuming everything was fine in the previous step, we’re ready to cut a part.   

1. Check to make sure the program coordinates are at 0, 0, 0.  If not, go through 

the “Setting Program Zero on the Machine Tool” section above. 

2. Go into jog mode and carefully move the tool down in the Z- direction to the 

part surface.  This should be at the program coordinate 0, 0, -1.  

3. Set this point as Program Zero by choosing Zero All from the Set button next 

to the Program label and choosing Yes in the dialog that follows. 
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4. Now jog the tool 0.5” UP (in the Z+ direction).  This places the tool in the 

correct starting position to begin cutting the workpiece. 

5. Choose the G-Code button in the Control Selection Box.   

6. Choose the Continuous radio button. 

7. Turn the machine tool spindle on and make sure everything is ready on the 

machine tool. 

8. Choose the Start button and the machine tool will begin to cut out your first 

part.  Always be on alert to choose the Feed Hold button or hit any key in 

case of emergency. 

9. Congratulations!  You’ve successfully cut your first part using FlashCut.  

Exiting the Program 

To exit FlashCut, choose Exit from the File menu.  This terminates 

communications with the Signal Generator and returns you back to Windows. 

Turning off the Electronics 

Always turn off the Signal Generator and Motor Driver when they are not in 

use.


